New and old Toyota car and truck content at Toyoland!

engine running rough, poor idle
November 4, 2008
i have an 89 LE V6 w/144,000 mi on it. when i bought it the engine pulsated and it died at idle (sitting, at stop signs etc). the radiator had been replaced and a tune up done, but the there was still stop leak in the coolant and it had two engine codes, both rich and lean fuel codes.The heater core was plugged too..We flushed the coolant, connected a vacuum hose or two, did a Bearyman's flush through the intake and the pulsating improved, the codes went away, and we get alittle heat, but when the car gets hot, (high rpms, extended idle) the pulsation comes back and occasionally so do the codes. It seems to run better in cold weather as well. there dont seem to be any other significant problems, but it does gets poor gas mileage. the exhaust is rotted, but it is behind the 02 sensor. we're kinda stumped at this point. anybody have some suggestions or ideas about how to fix her? any help would be appreciated. thanx....


November 5, 2008#1
The exhaust rot should be fixed - chances are, there is a spot infront of the O2 sensor as well - especially around the exhaust manifolds. If not, air can still be pulled into the exhaust system, through the leak, and confuse the O2 sensor. The O2 sensor itself could be "lazy" - not completely dead, but not giving the appropriate readings to the engine computer.

The hot engine behavior and the cooling issues you have - sounds like the cooling passages are still clogged up and/or the thermostat is shot. When you did the cooling service - did it have the Toyota red coolant or did it have the universal green coolant? If green - double check the waterpump as well - as the older green stuff used silicates as an additive package. That usually ended up forming mud or sand in the cooling passages and eat the seal on the water pump.

What exactly was done at the tune up? Just plugs and air filter or were the plugwires, cap and rotor, replaces as well? Was the igniter checked out as well? Fuel filter? Throttlebody cleaned? Could be severe carbon fouling - Intake manifold could be completely clogged with carbon and varnish, EGR valve could be caked with carbon as well. It does sound like there is a some heavy varnish gumming up the throttlebody and carbon could be fouling up the combustion chambers - could be why the Berryman's B12 stuff worked as well as it did. Might try something like Seafoam or more B12 to loosen things up.

The most common issue with this engine that results in hesitation, poor performance, and stuttering.stumbling for this, 2.5L V6 - 2VZ-FE engine, is that the timing could have jumped a tooth. Before you go crazy throwing money at this - check the timing. Very possible that it jumped a tooth when they changed the timing belt or soon afterwards.



Home Quick Menu bull; Search

This Toyota-focused site copyright © 2000-2022 Zatz LLC.