See a great deal of new and old Toyota car and truck content at the rest of Toyoland!

1995 sr5 pickup question
Read 4391 times
August 13, 2006, 12:38 AM
have a 95 pickup and cruise control doesnt work. no light comes on in the dash. any help?


August 13, 2006, 5:02 PM#1
If this restricted to the lamp or does the cruise control not work as well?

Did you try it at highway speed and set the cruise? Sometimes it takes some fidlling with the cruise stalk to get it to work. Is this the original cruise or an aftermarket fitment?

Problem could lie in the switch stalk for controlling the cruise, or the cruise control assembly under the hood. Make sure the cruise control unit is getting power (if electric) or has a good vacuum source (if vacuum actuated). Make sure the cables to the throttle are good and tight with no slack in them. You can take the top off the cruise control unit and manually move the throttle and see if the cables move in the unit.


August 13, 2006, 11:06 PM#2
hi, put in a new bulb and now the light works. will not operate at any speed


August 17, 2006, 4:09 PM#3
Then it sounds like you will have to run through the cabling, electricals, and hoses for the cruise control. Either it is not getting power(battery source for electronic cruise, vacuum for vacuum driven cruise control), too much slack in the throttle cable, bad switch on the steering column/wheel, or possible dead crusie control unit.


August 17, 2006, 10:49 PM#4
have vacuum, light on das comes on with steering wheel button, no power at both plugs on unit on firewall. maybe speed control box?


August 18, 2006, 4:49 AM#5
Possibly - I'll double check some service manuals and see if I can find a wiring diagram.



HomeSearch|

This Toyota-focused site copyright © 2000-2022 Zatz LLC.