See a great deal of new and old Toyota car and truck content at the rest of Toyoland!

Overheating
Read 2623 times
* February 23, 2009, 07:47:05 PM
Hey i have a 1990 toyota corona AT170 finished 89000KM i forget to connect the air filter sensor and the engine overheated can the air filter sensor cause this since it was not connected?

Logged


* February 23, 2009, 09:22:38 PM
#1
I\'m assuming you mean the sensor that plugs into the airbox?  For your engine (assuming this is an UK or Aussie Corona, fuel injected, engine?), should be a MAF (mass air-flow) sensor - some sensors do measure air temperature, but on this vintage of Toyota, more like that it just measures the volume of air.

Can this cause an engine overheat?  It is possible - depends on the situation.  If just let unplugged - this is unlikely.  If the ECM is not getting a valid air volume reading, the ECM will fall into a \"safe-mode\" and go off preset air/fuel/timing maps.  As mentioned, anything is possible - if the ECM did not go into a fail-safe mode, it is possible that it injected too little fuel, causing the car to run lean (excessively high exhaust temps and reduced ability to control cylinder temperatures).  You would definitely know when this happens, the car will not be very happy running.

Need a bit more info to help you out here.  Which engine are we talking about for the Corona?  When it overheated, by how much did it overheat?  How quickly did you notice?  How did the car run?  Thing that confuses me, if the MAF sensor was pulled out of the airbox or disconnected, the car would have a very tough time running at all.  Basically cannot keep an idle.  Any mods to the car/engine?

If the car was running just fine with the sensor unplugged, either you have a bad termperature sensor (temperature sending unit) or bad ECM, or you have a genuine overheating problem (clogged radiator, loss of coolant, bad thermostat).

Logged


* February 26, 2009, 12:37:02 AM
#2
The engine is a 5A-FE engine. when the temp gauge reached the red mark the car drove normal i can\'t say how long it overheated for. The air filter sensor was pulled out.

Logged


* February 26, 2009, 07:57:57 PM
#3
The car should have run a bit odd, with the sensor out like that.  If it didn\'t - you probably have an underlying problem that may or maynot have something to do with the overheating.  Get an oil change right away and test the coolant for combustion byproducts (chemical test).  If you didn\'t overheat the car too long - the engine should be perfectly fine.  If it did overheat long enough, there could be damage internally, from bearing damage to a blown head gasket.

Logged


 

Site created and maintained by David Zatz. He has written four car books.