See a great deal of new and old Toyota car and truck content at the rest of Toyoland!

1990 Toyota Corolla
Read 2617 times
* January 25, 2009, 02:48:33 AM
Hi,

I have a 90 corolla LE 4 door sedan automatic.  I had problems with the ignition switch sometimes it does not start.  When this happens i can use a wire from the starter to the battery and it starts no problem.  Now after so many months I have no power at all from the ignition.  It also has a non-functioning alarm that may be draining the battery.  Does anyone know how i would troubleshoot this?  How can i test the ignition switch (electrical part) behind the lock/cylinder?  I have a new one but I can\'t take it back if it is installed.

Thanks for any advice.

Gibs

Logged


* January 26, 2009, 04:05:03 PM
#1
I don\'t have the electrical diagram for a 6th gen Corolla with me - but does it have a 8-pin connector behind the switch?

If it does - then it probably is very similar to the 7th gen and 8th gen electrical connections (8th gen are the ones that I posted here).  For the 4 keyed switch positions (LOCK, ACC, ON, and START) and assuming that you are looking at the connections so that pins are be numbered (top row) 4 - 3 - 2 - 1, (bottom row) 8 - 7 - 6 - 5

On position ACC, Continuity on pins 2 - 3
On position ON, Continuity on pins 2 - 3 - 4 and 6 - 7
On position START, Continuity on pins 1 - 2 - 4 and 6 - 7 - 8

But to be the safe side - pick up a copy of Haynes or Chiltons repair manual at an autoshop or at the library - should be a wiring diagnostic guide that you should be able to use.  Given the age of the car and its behavior - probably pretty safe to assume that it is a bad switch.  There is a small chance that it could be the wiring from the switch to main wiring harness.  A quick visual inspection would catch most of that possibility - though buzzing the wires out with a multimeter would be a better method.  Good Luck.

Logged


 

Site created and maintained by David Zatz. He has written four car books.